用户登录
找回密码
立即加盟

Discuz! X2.5插件兼容 X2.0的官方教程

发表于 2012-6-13 09:26:49 显示全部楼层 3 4121

因康盛在新版Discuz! X2.5中,默认不在支持X系列版本的变量获取办法,官方说明如下:
  1. $_G['gp_xx']的写法默认不再支持,config.php中有兼容开关;
复制代码
故X2.0插件若需兼容X2.5,则需要重新设定下\config\config_global.php文件中的兼容控制开关,
  1. $_config['input']['compatible'] = 1;// $_GET|$_POST的兼容处理,0为关闭,
复制代码
保存后,即可使DiscuzX2.0原有插件,平滑过渡到X2.5环境下正常使用,而且对以往的插件系统的数据没有任何的影响。
快来试试吧!

以上教程基于康盛官方技术文库: http://dev.discuz.org/wiki
回复

使用道具 举报

tiger 发表于 2012-6-13 10:23:53 | 显示全部楼层
唉,最好是不开启兼容!
回复 支持 反对

使用道具 举报

~Strive~ 发表于 2012-6-18 20:43:37 | 显示全部楼层
很好,测试一下,如果行的话
回复 支持 反对

使用道具 举报

~Strive~ 发表于 2012-6-18 20:43:56 | 显示全部楼层
行好测试一下,如果行的话
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即加盟

本版积分规则

漂泊

管理员

主题

帖子

2161

积分
Ta的主页 发消息

娱乐更多>

网友分享更多 >

  • 【好支付】Discuz X用户组插件(tpgao_g
  • 【微商店】微信内置浏览器公众号支付时
  • 【微商店】关于提出出现不是授权版本的

Powered by Discuz! X3.2 © 2001-2013 Comsenz Inc.

小黑屋  |  手机版  |  Archiver  |   好团队网络科技 ( 沪ICP备12020767号 )     

点击立刻咨询
快速回复 返回顶部 返回列表